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SHIPCONSTRUCTOR LICENSE AGREEMENT 

1.  License Grant.    ShipConstructor  Software  Inc.,  #304  –  3960 Quadra  Street, Victoria,  B.C. Canada, V8X  4A3 
(“SSI”) grants to the person accepting this Agreement (the “Licensee”) a non‐exclusive, non‐transferable right to 
use (the “License”)  in object code form those program modules, application programming  interface (API), any 
other  materials  provided  by  SSI  under  this  Agreement,  and  all  upgrades,  revisions,  fixes,  updates  or 
enhancements  to  any  of  the  foregoing  (“Licensed Materials”)  specified  in  the  Licensee’s  purchase  order  or 
request  (“Order”)  solely  on  the  software  and  hardware  listed  in  the  Licensed Materials  manual  (“System 
Configuration”).   

2.  Academic Institutions/Trial Versions.   

A.  In  the  event  that  the  Licensee  qualifies  as  an  academic  institution  user  in  accordance  with  SSI’s 
specifications  (an  “Academic Licensee”),  the Academic Licensee  and  its  faculty,  employees  and  students 
may use  the Licensed Materials  for  the singular purpose of either  teaching,  training users or undertaking 
research provided that the Licensed Materials, and all copies of the Licensed Materials, remain at all times at 
the Academic Licensee’s premises and  the Licensed Materials are used  for no other purpose  than  that set 
forth above. The above restrictions are in addition to the restrictions on use set out in Section 5 below. 

B.  In the event that the Licensee receives a trial version of the Licensed Materials for evaluation purposes, 
the terms and conditions of this Agreement, excluding Sections 15‐19, shall continue to apply subject to the 
following provisions: 

(a)  the License pursuant to Section 1 above shall terminate at the end of the specified trial period; 

(b)  the Licensee shall return the Hardware Key to SSI immediately upon expiry of the specified trial period 
and in any event within 28 days of the expiry of the specified trial period; 

(c)  in  the  event  that  the Licensee does  not  return  the Hardware Key  in  accordance with  Section  2B.(b) 
above, SSI shall be entitled  to  invoice  the Licensee  for and  the Licensee shall pay  for  the costs of  the 
Hardware Key plus all shipping and handling expenses and SSI administrative charges; and 

(d)  in the event that the Licensee elects to and does acquire a Software License, the terms and conditions of 
this Agreement, excluding Section 2B herein, shall continue on and apply. 

 

3.  Ownership.   All  rights,  title  and  interests  in  and  to  the  Licensed Materials  and  related documentation  shall 
remain the sole property of SSI.  Licensee shall not remove or alter any proprietary rights notices on the Licensed 
Materials and the documentation, and shall reproduce such notices on any copies that it makes.  Licensee shall 
be liable for the security of the Licensed Materials and the documentation in its possession. 

4.  Expertise Required.    Licensee  is  responsible  for  evaluating whether  the  Licensed Materials meets  Licensee’s 
requirements, and  for operating  the Licensed Materials and  the  results obtained.   The Licensed Materials are 
intended  for ship modeling and construction purposes only, and must be used by a person who has expertise 
and knowledge  in  this  field.   The Licensed Materials  requires  independent confirmation of  the  reliability and 
accuracy of all designs, drawings and other Licensed Materials output. 

5.  Limitations on Use.   

  Licensee will: 

a)  make  no more  copies  of  the  Licensed Materials  than  are  necessary  for  the  Licensee’s 
installation  of  the  Licensed  Materials  and  to  create  back  up  copies  for  archival  or 
emergency restart purposes; 



b)  maintain a  log of  the number of and  location of all originals and copies of  the Licensed 
Materials; 

c)  include  SSI’s  copyright,  trademark  and  proprietary  notices  on  any  complete  or  partial 
copies  of  the  Licensed Materials  in  the  same  form  and  location  as  the  notice  on  any 
original work; 

d)   not attempt to defeat any copy protection; 

e)  not modify any documentation, including any user manuals; 

f)  not modify, translate, reverse engineer, decompile or disassemble the Licensed Materials; 

g)  not sublicense, transfer, assign, sell, loan, rent or lease the Licensed Materials other than as 
permitted in this Agreement; 

h)  use the Licensed Materials for its own internal use only; 

i)  not permit any third party to use the Licensed Materials; and 

j)  thoroughly  test  any  and  all  custom  interfaces  in  accordance with  general  engineering 
principles. 

6.  Delivery  and  Installation.   All Licensed Materials will  be  sent  to  the Licensee’s designated  email  address  or 
shipping address as specified  in  the Purchase Order.   Licensee agrees  to be  responsible  for  installation of  the 
Licensed Materials. 

7.  Term of License.   The License term commences on the delivery of the Licensed Materials to the Licensee, and, 
subject to Section 2B above, is either perpetual if so requested on the Order, or on a month to month basis that 
converts  to  a  perpetual  term  (a)  automatically  after  12 months  of  payment  of License  fees,  or  (b)  earlier  on 
Licensee’s payment of the balance of the perpetual License fee (prior monthly payments receiving 80% credit).  
All Licenses are subject to termination in accordance with this Agreement. 

8.  System Configuration.  Operation of the Licensed Materials requires use of the specified System Configuration, 
which Licensee shall acquire and implement.  SSI shall not be responsible for any operational problems caused 
by the System Configuration. 

9.  Hardware Keys.  Licensed Materials use requires “Hardware Keys” supplied by SSI, which can be used only at 
the site(s) authorized by SSI.  Upon failure of its System Configuration, Licensee may upon advising SSI use the 
Hardware Keys and Licensed Materials on another system and/or location. 

10.  License Fees.   Licensee shall pay  to SSI  the License  fees applicable  for  the Licensed Materials requested  in  the 
Order as either a perpetual License, or a month to month License. 

11.  Services.  Support services after the Warranty period (Section 15), as well as all installation, consulting, training 
and implementation services, are at an additional charge and are only provided if requested in the Order. 

12.  Taxes.  All amounts payable by Licensee to SSI are exclusive of all taxes such as sales, use, value added, custom 
duties, excise taxes and other similar government charges, all of which will be paid by Licensee.   If Licensee is 
required by law to withhold any taxes, then Licensee shall pay SSI a gross amount of money such that the net 
amount  received  by  SSI  after deducting  or withholding  the  required  taxes  is  equal  to  the  amount  of  the  fee 
originally charged by SSI. 



13.  Interest Charges.  If any amount payable under this Agreement is not paid within 30 days of becoming due, SSI 
shall have the right to impose a charge of 2% per month (24% annually) on the unpaid balance of the amount, 
from the due date until the date of receipt of all amounts in arrears including interest. 

14.  Purchase Orders.   Any Order from Licensee shall be deemed to incorporate this Agreement by reference.   Any 
terms and conditions on the Order shall not apply except for information which was requested by SSI.  All future 
Orders for additions to the original Order shall be subject to the terms of this Agreement. 

15.  Limited Warranty.    SSI warrants  that  during  a  period  of  90  days  from  the  date  of delivery  of  the Licensed 
Materials  to  Licensee,  the  Licensed  Materials  will  perform  substantially  in  accordance  with  the  Licensed 
Materials documentation specifications, when used in accordance with this Agreement on a properly operating 
System  Configuration.    SSI’s  sole  obligation  under  this Warranty,  and  Licensee’s  exclusive  remedy,  are  the 
“Maintenance Services” provisions (Section 18).  

16.  WARRANTY EXCLUSIONS.   THE LIMITED WARRANTY CONTAINED  IN SECTION 15  IS  IN LIEU OF ALL 
OTHER  WARRANTIES,  EXPRESS  OR  IMPLIED.    ALL  OTHER  CONDITIONS,  WARRANTIES,  AND 
REPRESENTATIONS, EITHER EXPRESS OR  IMPLIED, ARE EXCLUDED,  INCLUDING BUT NOT LIMITED 
TO  CONDITIONS,  REPRESENTATIONS  AND WARRANTIES  RELATING  TO MERCHANTABILITY  AND 
FITNESS FOR A PARTICULAR PURPOSE.  SSI DOES NOT WARRANT THAT THE LICENSED MATERIALS ARE 
COMPLETELY ERROR FREE OR THAT ITS OPERATION WILL BE CONTINUOUS AND UNINTERRUPTED.  

17.  Maintenance Term.  Maintenance Services shall commence on expiry of the Warranty and continue until the end 
of  the  calendar  year  requested  in  the Order  (“Maintenance Term”).   Maintenance  Services  are  automatically 
renewed on the same conditions (except the fees which may change) for successive periods of one year, unless 
Licensee cancels the renewal at least 60 days prior to the renewal date. 

18.  Maintenance Services.  During the Warranty period and the Maintenance Term, between the hours of 7:00 a.m. to 
5:00 p.m. Pacific Time  (Canada)  SSI’s help desk will use  reasonable  commercial  efforts  to  correct  errors  that 
Licensee identifies, by fixes or workarounds free of charge.  Additional support after the Warranty period can be 
purchased  from  SSI  at  the  current  list price.    If SSI determines  that  it  is unable  to make  the Licensed Materials 
perform substantially as warranted, Licensee may terminate the License and receive a refund of a portion of the License 
fees, determined on a  three year  straight‐line depreciation basis beginning on  the date of delivery of  the Licensed 
Materials  to  the Licensee.   Upon SSI delivering “Updates”  to address known errors  in  the Licensed Materials, 
Licensee  shall  install  and  use  the Updates within  30  days  of  their  delivery.   Upon  SSI  delivering  Licensed 
Materials with new functionalities (“New Releases”) as part of Maintenance Services, Licensee shall install and 
use the New Releases within 6 months of their delivery. 

  Maintenance Services will only be provided for the current version and prior versions of the Licensed Materials 
up to 12 months old. Maintenance Services for Licensed Material older than 12 months are at the sole discretion 
of SSI. 

19.  Excluded Events.  Maintenance Services do not include correction of errors due to: (a) Licensed Materials, which 
have been modified by any person other than SSI’s representative, (b) use of a version of the Licensed Materials, 
which has been  superseded by a more  current Update or New Release  for more  than 6 months,  (c)  incorrect 
operation of the Licensed Materials or use of the Licensed Materials for purposes other than ship modelling and 
construction, (d) any fault in the System Configuration, or incompatible third party Licensed Materials, or (e) use 
of the Licensed Materials with products or services not supplied or approved by SSI. 

20.  Licensee’s  Cooperation.    Licensee  shall  cooperate  in  investigating  each  reported  Licensed  Materials  error, 
including assisting in duplicating the error and verifying that the error has been corrected.  



21.  Loss of Data.   SSI  shall not be  responsible  for any  loss of or damage  to  files or data  caused by  the Licensed 
Materials,  or  be  required  to  restore  or  rebuild  files  or  data.    Licensee  shall  implement  adequate  backup 
procedures to avoid any loss of files and data. 

22.  Modifications.  SSI may,  from  time  to  time, provide Licensee with  revisions  to  the Licensed Materials  (the 
“Revised Licensed Materials”). Licensee shall test any external applications using the application programming 
interface (API) before applying the new version. While  it is SSI’s  intention that the Revised Licensed Materials 
shall  be  backward‐compatible  with  the  immediately  prior  version  of  the  Licensed Materials,  SSI  does  not 
guarantee or warrant that this shall be so, and SSI shall have no liability whatsoever to Licensee for any failure of 
the Revised Licensed Materials  to be backward  compatible with any prior version of  the Licensed Materials.  
Modifications requested by Licensee shall be subject  to prior written agreement as  to scope and  fees payable.  
Ownership of all Licensed Materials modifications shall vest in SSI. 

23.  Confidential  Information.    Each  party will  not  use  the  confidential  information  of  the  other  party  for  any 
purpose except for the purpose described in this Agreement, and shall not disclose it to any other person except 
on  a  confidential  basis  to  its  employees  and  representatives  who  have  a  need‐to‐know  the  confidential 
information  for such purposes.   This Section 23 shall not apply  to confidential  information which  (a)  is or has 
become readily available to the public in the same form other than by an act or omission of the receiving party, 
(b) was lawfully obtained in the same form by the receiving party from a third party not under an obligation of 
confidence to the disclosing party, (c) was in the receiving party’s possession in the same and material form prior 
to  its  receipt  from  the  disclosing  party  and  did  not  otherwise  originate  from  the  disclosing  party,  or  (d)  is 
required to be disclosed by operation of law. 

24.  Termination.   This Agreement may be  terminated by either party,  immediately by written notice,  if  the other 
party commits a breach of any material provision of this Agreement and fails to correct or rectify such breach 
within 30 days of receipt of the notice requesting it to do so. 

25.  Effect of Termination.  Upon termination of this Agreement Licensee shall immediately cease using the Licensed 
Materials, and within 14 days of termination return all Hardware Keys to SSI. 

26.  CONSEQUENTIAL  DAMAGES.    IN  NO  EVENT  SHALL  SSI  BE  LIABLE  FOR  ANY  LOSS  OF  DATA  OR 
PROFITS,  ECONOMIC  LOSS  OR  SPECIAL,  INDIRECT,  INCIDENTAL,  CONSEQUENTIAL  OR  PUNITIVE 
DAMAGES WITH RESPECT TO THIS AGREEMENT OR THE LICENSED MATERIALS, HOWEVER CAUSED, 
EVEN  IF  SSI  HAD  OR  SHOULD  HAVE  HAD  ANY  KNOWLEDGE  OF  THE  POSSIBILITY  OF  SUCH 
DAMAGES. 

27.  DAMAGES LIMITATION.  THE MAXIMUM LIABILITY OF SSI FOR ALL CLAIMS AND DAMAGES OF ANY 
KIND, WHETHER FOR FUNDAMENTAL BREACH OR ANY OTHER CAUSE UNDER THIS AGREEMENT, 
SHALL BE LIMITED IN THE AGGREGATE TO THE TOTAL OF ALL FEES PAID BY LICENSEE. 

28.  LIMITATION OF NON‐APPLICABILITY.  IN SOME JURISDICTIONS THE EXCLUSION OR LIMITATION OF 
WARRANTIES OR LIABILITY MAY NOT BE APPLICABLE, AND  IN  SUCH  JURISDICTIONS  SSI HEREBY 
LIMITS ITS LIABILITY TO THE FULLEST EXTENT PERMITTED BY LAW. 

29.  Applicable Law.  This Agreement shall be subject to and construed in accordance with the laws of the Province 
of British Columbia, Canada, excluding  its conflict of  laws rules and the application of the UN Convention on 
Contracts for the International Sale of Goods. 

30.  References.  SSI shall be allowed to incorporate Licensee’s name in SSI’s customer reference list and to use it for 
marketing. 

31.  Dispute.  If any dispute arises under this Agreement, a good faith attempt to resolve the dispute will be made by 
senior management of both parties  at  a mutually  agreeable  site  and  time.    If  the parties  are unable  to  reach 



agreement within 30 days after a request for such meeting, the dispute shall be referred to arbitration in English, 
before one arbitrator in Victoria, British Columbia, Canada, in accordance with the Commercial Arbitration Act 
of British Columbia.  

32.  Entire Agreement.   This Agreement contains  the entire agreement between  the parties and shall supersede all 
prior discussions and agreements between the parties regarding its subject matter. 

33.  Amendment.    Any  amendment  of  this  Agreement  must  be  in  writing  and  signed  by  duly  authorized 
representatives of the parties. 

34.  Waiver.   The waiver by any party of a breach by the other party of this Agreement shall not be construed as a 
waiver by such party of any succeeding breach by the other party of the same or another provision. 

35.  Assignments.   Licensee may  not  assign  or  transfer  the License  or Licensee’s  rights  or  obligations under  this 
Agreement without SSI’s prior written consent, and any such assignment or  transfer without consent shall be 
null and void. 

36.  Successors and Assigns.   This Agreement will bind and enure to the benefit of the parties and their respective 
successors and permitted assigns. 

37.  Severability.  In the event that any provision of this Agreement is declared invalid, illegal or unenforceable by a 
court having jurisdiction, then the remaining provisions shall continue in full force and effect. 

38.  Force Majeure.  Except as related to Licensee’s obligation to make payments to SSI, neither party shall be liable 
for delays or non‐performance if such delays or non‐performance are beyond such partyʹs reasonable control.  A 
delayed party shall promptly notify  the other party  in writing stating  the cause of  the delay and  its expected 
duration  and  shall  use  commercially  reasonable  efforts  to  remedy  a  delay  or  non‐performance  as  soon  as 
reasonably possible. 

39.  Survival.   The provisions of Sections 3, 21, 23, 25, 26, 27 and 31 shall survive  the expiry or  termination of  this 
Agreement. 

40.  Language.  It is the express will of the parties that this Agreement and related documents have been prepared in 
English.   C’est  la  volonté  expresse  des  parties  que  la  présente Convention  ainsi  que  les  documents  qui  s’y 
rattachent soient rédiges en anglais. 

V2006‐12 
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Project Management 

Project Management 
The Project Management manual helps project managers organize and administer projects and the team 
working on projects. 

 

Administrator 
Administrator is a stand‐alone utility that lets you set up and manage projects. See Administrator in the 
Appendix for more details on working with Administrator. 

Start Administrator 

To start Administrator 

1. Choose Start > All Programs > ShipConstructor2006 > Utilities > Administrator2006. 

The Select Database Server window appears. 

2. Select the Server Name from the list (or enter a name at the bottom of the window). 

3. Enter the system administration Login Name and Password. 

A default system administration account exists: 

• Login Name: ShipConstructor 

• Password: ShipCon 

4. Click OK to close the Select Database Server window. 

The Administrator window appears, listing all projects on the server. 
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Refresh the Project List in Administrator 

To refresh the project list in Administrator 

1. In Administrator, choose Server > Refresh Project List. 

Disconnect Administrator from the Current Server 

To disconnect Administrator from the current server 

1. In Administrator, choose Server > Disconnect. 

Connect Administrator to a Server 

To connect Administrator to a server 

1. In Administrator, choose Server > Connect to open the Select Database Server window. 

See Start Administrator (page 1) for details. 

Manager 
Manager is a utility that lets you set up project settings, project libraries, and user permissions. 

To start manager 

1. In ShipConstructor, choose ShipConstructor > Manager. 

2. The Manager window appears. 

 

 

See Manager in the Appendix for further details. 

Project Set Up & Maintenance 
Before you begin work on a vessel, you must set up a ShipConstructor project for it. A project is the container 
for the vessel’s 3D model, libraries, and drawings. 

A project consists of three things: 

• A project file (*.PRO) 

• Several folders containing drawings 

• A database containing all the project’s data 
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Note: The terms project and database are sometimes used synonymously. 

Create a Project 
To create a project 

Note: You must have administrative privileges in ShipConstructor to create a project. 

1. Choose ShipConstructor > Project > New Project to open the New ShipConstructor Project window. 

 

2. Enter the Project Folder name or click the   button and select the folder. 

Note: Do not use an existing folder that already contains a ShipConstructor project. Each 
ShipConstructor project must be in its own folder. 

3. Select the Project Server. 

4. To use a single template for the entire project, turn on Use the same template for all areas, click the   
button for Users & Settings, and select a template. 

To use a different template for each discipline, turn off Use the same template for all areas, click the   
button for each discipline, and select a template. 

You can select one of two project templates included with ShipConstructor: 

• C:\Program Files\ShipConstructor2006\Project Templates\MetricTemplate.xml 

• C:\Program Files\ShipConstructor2006\Project Templates\ImperialTemplate.xml 

Or you can select any ShipConstructor project and use it as a template. (ShipConstructor will remove 
any project‐specific items and retain things like templates, stocks, and general settings.) 

5. Enter the User Name and Password for a user with administrative privileges in ShipConstructor. 

The default administrative account is: 

• User Name: ShipConstructor 

• Password: shipcon 

6. Click OK to create the project. 

It may take a few minutes for ShipConstructor to create the project. 
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Note: If the project template is from an older version of ShipConstructor, you may see a message 
similar to the following. 

 
You must update the project template to the latest version of the database. See Update a Project 
Database Version (page 12). 

You can now register to the project. If you created the project from one of the two project templates 
included with ShipConstructor, enter admin for the Log in name and leave the Password blank. 

Copy a Project 
You can copy a project or database from within ShipConstructor or Administrator. 

To copy a project (in ShipConstructor) 

1. Choose ShipConstructor > Project > Copy Project to open the Copy Project window. 

 

2. Select the Project File you want to copy by clicking Browse under Source Project. 

 

3. Enter the Project Name for the new project. 

4. Select a Folder for the new project by clicking Browse. 

ShipConstructor will create a new project folder (with the same name as the Project Name) within the 
Folder you specify. 

5. Enter the Username and Password for a user with administrative privileges in ShipConstructor. 

6. Click OK. 
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7. ShipConstructor copies the project database and all drawing files and then automatically logs you into 
the new project. 

Note: If the source project is from an older version of ShipConstructor, you may see a message 
similar to the following. 

 
You must update the project template to the latest version of the database. See Update a Project 
Database Version (page 12). 

To copy a database (in Administrator) 

1. In Administrator, right‐click on the project and choose Copy. 

 

The Copy Database window appears. 

 
2. Enter the name for the new project. 

3. Click OK to copy the project. 

The new project database is identical to the original project database but with a new Project GUID. 

Update a ShipConstructor2005 Project 
To update an existing ShipConstructor2005 project to 2006 format, you must have both ShipConstructor2005 
and the Project Updater application installed on your machine.  The Project Updater application is a separate 
installation and is installed from the ShipConstructor 2006 CD.   

Note: Production drawings are not updated as part of the Project Update process. 

Updating Your ShipConstructor2005 Project 
The Project Updater creates a new ShipConstructor 2006 project filled with data from your 
ShipConstructor2005 project model. Your ShipConstructor2005 project model remains unaffected by the 
update process. 
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To update your project 

1. Open your project in ShipConstructor2005. 

2. Run the command SC2005UPDATE to open the Project Update to 2006 window. 

 

3. Enter the project folder where you want the 2006 version of your project to be located. The final 
folder name will be used for your project name (for example, specifying 
C:\Projects2006\SC2006Demo will give you a project name of SC2006Demo). 

4. Enter the User Name and Password of a database administrator user. For more information on 
database administrator users, see Grant Administrator Access to a User (page 21). 

5. The Update Modules box offers the option of selecting certain portions of the project to update. 
When the window opens, everything is checked automatically, so you must uncheck any module 
that you do not want updated. You will notice that some portions are not able to be unchecked, 
and that some portions will be checked automatically when checking other portions. This is due to 
dependencies between modules (for example, all projects need General and pipe parts need Pipe 
stocks). 

6. Click Update to begin the update process. This process may take a long time and require some user 
interaction. There are two large progress indicators on the screen. The upper progress bar indicates 
overall progress. It shows approximately how far into the update process you are and lets you 
estimate how much longer the update will take.  The lower progress bar indicates the progress in 
the current step, such as importing pipe elbow stocks. 

7. During the course of the update you will likely see numerous Action Items. Action items indicate 
what needs to be fixed in the new ShipConstructor 2006 project model before the model can be 
used. Many of these action items may be trivial such as needing to set a stock’s weight in the stock 
catalog, while other action items may be more serious indicating that some parts were corrupt and 
not able to be brought across.   

8. A log of the action items has been saved for you in the LogFiles folder of the destination project, so 
that you can access it using the Action Item Browser (see Resolving Action Items (page 7)).  You may 
examine this file now by clicking Export Log. 

6 © 2006 ShipConstructor Software Inc. All Rights Reserved. 



Project Set Up & Maintenance 

Resolving Action Items 

To resolve action items in your project 

1. Open your project in ShipConstructor 2006. 

2. Run the command SCACTIONITEM. The Action Item Browser window appears. 

 

3. Click the   button next to Action Item Log to browse for your ActionItem.csv file. 

4. Action items are broken down by module and have a priority of Low, Medium, and High. 

 

5. If the action item relates to a specific ShipConstructor part, double‐clicking the action item or 
selecting the item and clicking the Zoom button will open the corresponding model drawing and 
zoom to the appropriate part. You can now fix the problem and save your drawing. 

Open a Project 
To open a project 

1. Choose ShipConstructor > Navigator to open Navigator. 

• If you do not currently have a project open (for example, after initially starting ShipConstructor), 
the Select ShipConstructor Project window appears. 

• If you currently have a project open, Navigator appears. Select the project from the component list 
(for example, SC2006Demo), and click Change Project to open the Register Project window. 
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2. Select the project from the list or click Browse to locate a project file. (A ShipConstructor project file has 
a *.pro extension.) 

3. Enter your User name and Password. 

Note: For the project templates, the User name is ShipConstructor and the Password is ShipCon. 

If you do not have a user account, ask your system administrator to set one up, or see User Accounts 
(page 19) for details. 

4. Click Open. 

Note: If this is the first time you open a project after starting ShipConstructor, the Licensing window 
appears. See Get Licenses in the Structure manual for details.  

Monitor Project Activity 
Many project database administration functions require exclusive access to a project database. You can 
monitor project activity to check for active connections to the project database. 

To monitor project activity 

1. In Administrator, select the project you want to monitor. 

2. Choose Project > Show Connected Processes to open the Connected Processes window. 

The window lists all processes currently connected to the project database. 

If the window is empty, there are no processes currently connected to the project database. 

Click Refresh to refresh the display in the Connected Processes window. 

3. Click Close to close the Connected Processes window. 

Delete a Project 
To delete a project 

1. In Administrator, select the project you want to delete. 

2. Choose Project > Delete. 

8 © 2006 ShipConstructor Software Inc. All Rights Reserved. 



Project Set Up & Maintenance 

Back Up a Project 
It is important to create backups of your project periodically. You can manually create a backup at any time, 
or set up scheduled (automatic) backups. 

Manually Back Up a Project 
You can manually back up one or multiple projects at one time. 

To manually back up a project 

1. In Administrator, select the projects you want to back up. 

2. Choose Project > Backup to open the Select Backup Location window. 

3. Select the location to save the backup file and, if desired, modify the File Name of the backup file. 

Note: If you select an existing file from the folder tree or enter a File Name of an existing file, the 
existing file will be replaced with the new project backup file. 

4. Click OK. 

Note: If you selected multiple projects in Step 1, the Select Backup Location window will appear for 
each selected project. 

Set Up Scheduled (Automatic) Project Backups 
You can schedule automatic backups for one or multiple projects at one time. 

To set up a scheduled (automatic) project backup 

1. In Administrator, select the projects to schedule automatic backups for. 

2. Choose Project > Schedule Backup to open the Backup Schedule window. 

 

 

3. Select when and how often the scheduled backup will occur: 

• Once on a specific date and time. 

• Weekly on a specific day and time. 

• Daily at a specific time. 
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And specify the date, day, and time. 

4. Enter the Backup Folder, or click   and select a folder on the server machine to place the backup file 
in. 

5. Click Add to create the scheduled backup job. 

Note: If your SQL Server Agent is not currently running, the following message appears. 

 

6. Click Yes to start the SQL Server Agent. The SQL Server Agent must be running in order for the 
scheduled backup job to occur. 

Note: You can check the status of scheduled backups and start and stop the SQL Server Agent at any 
time by clicking the Service tab in the Backup Schedule window. See Monitor the Backup Service 
(page 10) for details. 

The scheduled backup job appears in the Current scheduled backup jobs list. 

Note: After a Once on scheduled backup has occurred, it will no longer appear in the Current 
scheduled backup jobs list. 

7. Click OK to close the Backup Schedule window. 

Remove a Scheduled Backup Job 

To remove a scheduled backup job 

1. In Administrator, select the projects to remove a scheduled backup job from. 

2. Choose Project > Schedule Backup to open the Backup Schedule window. 

3. Select the scheduled backup job from the Current scheduled backup jobs list. 

4. Click Remove. 

Monitor the Backup Service 

To monitor the backup service 

1. In Administrator, select any project. 

2. Choose Project > Schedule Backup to open the Backup Schedule window. 

3. Click the Service tab. 

The Current Status indicates if the SQL Server Agent is Stopped or Running. 

To start the SQL Server Agent, click Start Service. 

To stop the SQL Server Agent, click Stop Service. 

To ensure that scheduled backups occur, make sure the Current Status is Running and that Auto-start 
with OS is on (so the SQL Server Agent automatically starts when the server is rebooted). 
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Restore a Project Backup 
To restore a project backup 

1. In Administrator, select the project you want to restore. 

2. Choose Project > Restore. 

The Confirm Restore window appears. 

3. Click OK. 

The Select backup file window appears. 

4. Select the backup file you want to restore. 

5. Click OK. 

ShipConstructor automatically creates a backup of the original project in the default backup directory 
(usually C:\Program Files\Microsoft SQL Server\MSSQL\BACKUP\). 

Transfer a Project to Another Server 
You can move a project to another server within your organization or transfer a copy of a project to another 
server outside your organization (for example, to outsource a portion of the work). 

To move a project to another server 

1. Back up the project on its original server (see Manually Back Up a Project (page 9)). 

2. Copy the backup file to the project directory. 

3. If you are transferring the project to a remote location, package the entire project directory into a single 
archive file using a compression utility like WinZip. Then transfer the package to the new server and 
unpack it. 

If you are transferring the project to another server at the same location, you do not need to package it. 
You can simply copy the entire project directory to the new server. 

4. On the new server, create a new project and give it the same name as the original project (see Create a 
Project (page 3)). 

5. Restore the backup created in Step 1 onto the new server (see Restore a Project Backup (page 11)). 

6. Move the project directory that you copied in Step 3 to the project directory you created in Step 4. 

7. On the new server, open the *.PRO file using a text editor like Notepad and do the following: 

• Change Server=<OldServerName> to Server=<NewServerName>. 

• Make sure Database=<DBName> points to the correct project database. 

8. Save the *.PRO file. 

Compact a Project 
Periodically while working on a project, you may want to compact the project to reduce the amount of space 
it occupies on the server’s hard drive. 

To compact a project 

1. In Administrator, select the projects you want to compact. 
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2. Choose Project > Compact. 

It may take several minutes for ShipConstructor to compact each project. 

The results of the compacting process appear in the bottom portion of the Administrator window. 

Update a Project Database Version 
ShipConstructor Software Inc. periodically releases updates of ShipConstructor containing new features and 
improvements. Each update includes a new version of the ShipConstructor database. In order to make use 
of an update, you must download and install a file for updating the ShipConstructor software (see Updating 
ShipConstructor in the Installation Guide). Once the update is applied, you can update your ShipConstructor 
projects to the required version. 

To update a project database version 

1. In Administrator, select the projects you want to update. 

2. Choose Project > Update to open the Update Project Databases window. 

3. Select the database version you want to update the projects to. 

4. Click Start. 

ShipConstructor automatically creates a backup of the selected projects in the default backup directory 
at <SQLDataRoot>\BACKUP\<database name><current date&time>.bak. 

Note: If any errors occur during the update of your project, the project automatically reverts to its 
original state. 

Once the update is complete, you can view a log file of the update by clicking View Log. 

5. Click Close. 

Re-attach a Project Database to Its Server 
A project database must be associated with or attached to a specific server. In certain rare cases, a project 
may become detached from its server (for example, if you re‐install the server). If a project becomes 
detached from its server, you must re‐attach it. 

To re-attach a project database to its server 

1. In Administrator, choose Tools > Re-attach Database. 

The Re-attach Databases window appears, listing detached databases for the current server. 

2. Select the project database you want to re‐attach. 

3. Click Attach. 

4. Click Close to close the Re-attach Databases window. 

Edit Project Database Raw Data 
In certain rare cases, you may need to view and edit the raw data contained in the project database (for 
example, to analyze specific problems or repair errors). By editing the project database raw data, you can 
easily destroy valuable data. We recommend that only knowledgeable users attempt to edit the database. 
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To edit project database raw data 

1. In Manager, choose Database Utilities > Raw Data to open the Database Raw Data window. 

2. Under Server Objects, select a Table or Procedure to display its values. 

3. Edit the values. 

4. To execute a procedure, click Execute. 

5. Click OK to close the Database Raw Data window. 

ShipConstructor Report 
Starting ShipConstructor Report 
ShipConstructor 2006 Report can be started one of two ways: 

1. Choose ShipConstructor2006 > Reports2006. 

2. Click the Report button,  , on the main ShipConstructor 2006 toolbar. 

If you are already connected to a ShipConstructor project while opening Report using the latter option, you 
will be automatically connected to that project within the report application. If you are not already 
connected to a ShipConstructor project, then you will be prompted to connect to one. You will also be 
prompted at this time to acquire a ShipConstructor report license. 

   

Creating and Editing Report Definitions 
Report definitions can be created and edited via the Report Definitions window. To begin editing report 
definitions, select Reports > Report Definitions from the main menu. 
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Report Definition Window  

 

The Report Tree ‐‐ The tree in the Report Definitions window lists all report definitions you have created and 
breaks them down by discipline and type. 

Report Name ‐‐ The name that the report is referred to in the editing and generating portions of 
ShipConstructor Report. 

Report Title – The title of the report. This appears at the top of each page of the report. 

Paper Size ‐‐ The size of the generated report. 

Paper Orientation – The orientation of the generated report. 

Inc. Page Header – This determines whether each page of the report contains the standard page header. 

Imperial Disp. 1/16” – This determines whether length values in the report are displayed in standard 
imperial format or not. 

Import and Export XML ‐‐ Report definitions can be imported and exported either via XML or directly from 
another ShipConstructor project. 

New Report ‐‐ This button lets you create a new report definition beneath the selected discipline and type. 

Delete Report ‐‐ This button lets you delete the selected report definition. 

Edit Report… ‐‐ This button lets you begin editing the selected report definition. 

OK and Cancel ‐‐ These buttons let you save or discard the changes you have made since you opened the 
Report Definition window. Until you click OK, changes you have made to the report definitions are not 
available when you generate a report. 
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Edit Report Definition Window 

 

The Report Section Tree ‐‐ The report section tree shows a breakdown of all the available sections you can 
include in the current report and the report sections you have chosen to include. Selecting one of the 
included sections shows you the fields you have chosen to include from that section. Certain sections can 
only be included by including the appropriate section above it. If you select one of these sections, the 
corresponding parent sections are automatically selected, too.

Include – This is where you select the related report section to include in this report. 

SectionName – The name of the report sections. 

Font Size – The size of the font used for data in this report section. 

Header – Options to determine the behavior of the section header in the case of a blank section. 

Fore Color – The color of the text and other items in this report section. 

Back Color – The color of the background of this report section. 

Header Fore Color – The color of the text and other items in the background of this report section. 

Header Back Color – The color of the background of the header of this report section. 

The Section Fields List  ‐‐ The Section Fields list shows each of the fields chosen for the selected report 
section. The fields are in the order they will appear in the report and can be moved up and down as desired. 
Report fields can be added and removed via the Add Field and Remove Field buttons.

Field Name – The name that the current field is referred to as. 

Display Name – The name for the field shown in report section headers in a generated report. 

Field Width – The width of the field in the generated report. 

Display Units – The units that values in this field should be converted to and displayed as. 

Dec. Places – The number of decimal places to round numeric fields to. 

Alignment – The filed alignment for the current field. 

Edit Grouping  ‐‐ Opens the Edit Section Grouping window and lets you group the current report section 
where the values in the selected field are the same across multiple rows in the report. Other calculated fields 
(Sum, Avg, and Count) can be included in the group section based on available fields from that section. That 
is, the sum of all profile pieces can be included where the report is grouped by the stock of those parts.
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Edit Sorting – Opens the Edit Section Sorting window and lets you sort the current report section by as 
many fields as you want. The sorting is applied in the order of the fields you have selected.

 

Generating a Report 
All reports are generated based on the assembly or system you select before you generate the report. This 
lets you generate the report for the whole project, only a specific unit, or by as small an assembly or system 
branch as you want. 

Generating a Product Hierarchy Report 

To generate a report based on a product hierarchy 

1. Choose ShipConstructor 2006 > Reports2006 and select the Product Hierarchy tab in the Reports 
window.  

2. Select the product hierarchy you want to generate the report for in the secondary tab.  
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3. Select the assembly you want to generate the report for in the product hierarchy tree for the selected 
product hierarchy. Once you have selected the appropriate assembly, you need only select the target 
report definition from the drop‐down list of report definitions and click Generate,   .  

The selected report is generates and the results appear. 

 

Generating a Distributed Systems Report 

To generate a report based on a Pipe or HVAC system 

1. Choose ShipConstructor2006 > Reports2006 and select the Distributed Systems tab in the main Reports 
window.  

2. Select either the Pipe or HVAC secondary tab.  

3. Select the Pipe or HVAC system (or branch) you want to generate the report for from the system tree. 
Once you have selected the appropriate system, you need to only select the target report definition from 
the drop‐down list of report definitions and click Generate,  . 

The selected report is generated and the results appear. 
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Exporting a Generated Report 
Once you have generated a report (see Generating a Report (page 16)) you may want to export the report to 
another format for calculation or presentation purposes. Reports can be exported to four other formats: 
Microsoft Excel, HTML, Adobe PDF, and Rich Text Format (RTF). 

To export a report, generate the report and then click Export from within the report. You will be prompted 
for the type and location of the exported report. 

 

The report is exported to the selected location when you click OK. 
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User Accounts 
Before beginning work on a project, you must set up a user account for each user. Whenever a user opens a 
project, they must log on to their user account. User accounts let ShipConstructor track project changes by 
user. User accounts also let you control user access to projects and ShipConstructor features. 

Create a User Account 

To create a user account 

1. In Administrator, choose Tools > Manage to open the Manager Users window. 

 

 

2. Click Create User to open the New ShipConstructor User window. 

3. Enter a User name and Password (and confirm the password) for the new user. 

4. Select the projects that you want the new user to have access to. 

5. Click OK. 

Copy a User Account 
If you are creating a new user account that will have similar privileges to an existing account, you can save 
time by copying a user account. 

To copy a user account 

1. In Administrator, choose Tools > Manage to open the Manage Users window. 

2. Select an existing user account that has privileges similar to the privileges you want for the new user. 

3. Click Copy User to open the Copy ShipConstructor User window. 

4. Enter a User name and Password and confirm the password for the new user. 

5. Click OK. 

Delete a User Account 

To delete a user account 

1. In Administrator, choose Tools > Manage to open the Manage Users window. 

2. Select the user account. 

3. Click Delete User. 
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The Confirm Delete User window appears. 

4. Click OK. 

The Transfer Revision History window appears. 

You must transfer the deleted user’s revision history for each project to another user. In other words, 
the Transfer Revision History window appears for each project the user belongs to. 

5. Select the user you want to transfer the revision history to. 

6. Click OK. 

Add a User to a Project 

To add a user to a project 

1. In Administrator, choose Tools > Manage to open the Manage Users window. 

2. Check the check box for the project to add the user to. 

Note: The user will not have any permissions in the project. You must set up the user’s permissions. 
See User Permissions (page 21). 

Remove a User from a Project 

To remove a user from a project 

1. In Administrator, choose Tools > Manage to open the Manage Users window. 

2. Uncheck the check box for the project you want to remove the user from. 

Note: If you remove a user from all projects, ShipConstructor will delete the user account (see Delete 
a User Account (page 19)). If you plan to add the user to another project, do so before removing the 
user from all other projects. 

Change User Passwords 

To change a user password 

1. In Administrator, choose Tools > Manage to open the Manage Users window. 

2. Select the user account that you want. 

3. Click Change Password to open the Enter Password window. 

4. Enter a new Password and Confirm the password. 

5. Click OK. 

Change the System Password 
The ShipConstructor user is the default system administration user account. The default password for this 
account is shipcon. 

To change the system password 

1. In Administrator, choose Tools > Manage Users 

2. Menu Tools > Manage Users 
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Toolbar............  
Right-click....... Manage Users 
Procedure....... User Accounts (page 19)  

Opens the Manage Users window, letting you create and edit user accounts. 

ShipConstructor Users 
Lists all ShipConstructor user accounts and which projects each user account has access to. DB Admin 
indicates user accounts with system administrator privileges. 

Change Password 
Lets you change the password for the selected user account. 

New User 
Creates a new user account. 

Copy User 
Creates a new user account that has access to the same projects as the selected user account. 

Delete User 
Deletes the selected user account. 

3. Tools > Change ShipConstructor User Password to open the Enter Password window. 

4. Enter a new Password and confirm the new password. 

5. Click OK. 

Grant Administrator Access to a User 
In order for a user to create a new project, or use the Project Split & Merge functions, they must have 
administrator access. 

To grant administrator access to a user 

1. In Administrator, choose Tools > Manage to open the Manage Users window. 

2. Check the check box under DB Admin for the user. 

User Permissions 
User permissions are a way to prevent specific users from using specific functions. For example, you may 
want to restrict all structural designers so they can only use structural functions (and not, for example, pipe 
functions). Or you may want to restrict a junior designer or a user who is new to ShipConstructor from 
using features that require greater skill or responsibility. This helps prevent mistakes and gives new users 
confidence knowing that they cannot inadvertently destroy valuable data. 

You set up user permissions by project. In other words, a user could have limited permissions on one 
project, but greater permissions on another project. When you set up user permissions, you do so for the 
current project. 

You can set up user permissions either for individual users or for groups of users. 
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Permission groups are a way of setting up user permissions for groups of users. You first create permission 
groups and assign users to those groups and then set up the permissions of each group. Each user then 
inherits the permissions of the groups they belong to. 

When setting permissions for a user group, you explicitly allow or deny each permission for the group. 
Allow gives permission to all users in the group and deny denies permission for all users in the group. 

If there is a conflict between the permission of a user and the permission of a group that the user belongs to, 
the user permission takes precedence. If a user belongs to more than one group and there is a conflict 
between the permissions of each group, the user is denied permission. 

Edit User Permissions 
To edit user permissions 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. In the Users list, select the user you want to edit. 

3. In the Permission Groups list, check the check boxes of the groups that you want the user to belong to. 

4. Under User Overrides, set the Access for each feature to one of the three options: 

• Allowed – The user has permission to use the feature, even if they belong to a permission group that 
does not allow access to the feature. 

• Denied – The user does not have permission to use the feature, even if they belong to a permission 
group that does allow access to the feature. 

• From Group – The user’s permission to use or not use the feature is based on the permission groups 
that the user belongs to. (If the user belongs to more than one group and there is a conflict between 
the permissions of each group, then the user is denied permission.) 

5. Click OK to close the User Permissions window. 

Create a Permission Group 
To create a permission group 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. Under Permissions Groups, click New. 

3. Enter a name for the permission group and press Enter. 

Add and Remove Users to and from Permission Groups 
To add and remove users to and from permission groups 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. In the Users list, select the user you want to add or remove from permission groups. 

3. In the Permission Groups list you need to do two things: 

• Check the check boxes of the groups that you want the user to belong to. 

• Uncheck the check boxes of the groups that you do not want the user to belong to. 
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Note: If you add a user to two permission groups and there is a conflict between permissions in 
those groups, then the user is denied permission. 

Edit Group Permissions 
To edit group permissions 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. Under Permission Groups, select the group you want to edit. 

3. Click Edit to open the Edit Permission Group window. 

4. Set the permission for each feature: 

• Allow – Users in the group have permission to use the feature. 

• Deny – Users in the group do not have permission to use the feature. 

Note: You can override group permissions for specific users by setting their user permissions (see 
Edit User Permissions (page 22)). 

5. Click OK to close the Edit Permission Group window. 

Export Permission Groups 
You can export permission groups to an XML file (for example, to import into another project or to edit 
using other software). 

To export permission groups 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. Click Export XML to open a File Browser. 

3. Enter a name for the XML file. 

4. Click Save. 

Import Permission Groups 
You can import permission groups from another project or from an XML file that you have exported from a 
project. 

To import permission groups 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. Click Import to open a File Browser. 

3. Select a project file (*.PRO) or XML file (*.XML). 

4. Click Open. 
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Delete Permission Groups 
To delete a permission group 

1. In Manager, choose General > User Permissions to open the User Permissions window. 

2. Under Permissions Groups, select the permission group you want to delete. 

3. Click Del. 

Licenses 
ShipConstructor is a suite of software modules that you can purchase separately. When you purchase a 
module, you purchase a license to use that module. In addition, when you purchase a module, you purchase 
it at one of several levels (Level 1, Level 2, and so on). Lower levels let you work with fewer parts per 
project, and higher levels let you work with greater numbers of parts per project. (For more information on 
ShipConstructor modules and licensing, visit www.ShipConstructor.com.) 

When you purchase ShipConstructor, you receive a hardware lock that contains your particular license 
information. A hardware lock is a small device that you plug into the USB port of your computer. There are 
two types of hardware locks: local locks and network locks. A local lock must be installed on the same 
computer that is running ShipConstructor; only the user at that computer can access the licenses on the local 
lock. A network lock can be installed on any network computer; any ShipConstructor user on the network 
can access the licenses on the network lock, allowing users to time‐share licenses. (See the Installation Guide 
for more information on hardware locks.) 

Users can check out a license (from a list of available licenses) from the Licensing window. (The Licensing 
window appears, by default, when a user starts ShipConstructor. You can also open the Licensing window 
by choosing ShipConstructor > Licensing.) Once all licenses have been checked out, no other users can use 
that module until a license is released. (The system administrator can release checked out licenses, making 
them available for other users.) 

License Service 
The License Service is a Windows service that lets ShipConstructor communicate with hardware locks. The 
License Service is automatically installed with ShipConstructor. 

License Monitor 
The License Monitor is a utility that lets you list license information. See License Monitor (page 38). 

Change the License Service Port 
By default, the License Service uses port 3960 for communication. If there are other applications installed on 
your network that use port 3960, you must change the License Service port to avoid any conflicts. Otherwise, 
leave the License Service port set to 3960. 

To change the license service port 

Important: You must perform this procedure on all computers that have ShipConstructor installed. 

1. Open the file C:\Program Files\ShipConstructor 2006\ShipConstructor\Server.Config using Notepad or 
another text editor. 
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2. Edit <Port>3960</Port>to change the port setting. 

3. Save the Server.Config file and close it. 

4. In ShipConstructor, choose ShipConstructor > Licensing to open the Licensing window. 

5. Click Network to open the Network License Settings window. 

6. Change the Port setting to match the port setting you entered in Step 2. 

7. Click OK to close the Network License Settings window. 

8. Click OK to close the Licensing window. 

9. Choose Start > All Programs > ShipConstructor2006 > Utilities > License Monitor to open the License 
Monitor. 

10. Change the Port setting to match the port setting you entered in Step 2. 

11. Click Connect. 

12. Close the Licensing Monitor. 

Note: Whenever you edit the Server.Config file, you must restart the License Service (see Restart the 
License Service (page 25)). 

Restart the License Service 
To restart the license service 

1. Choose Start > Control Panel to open the Control Panel. 

2. Double‐click Administrative Tools. 

3. Double‐click Services to open the Services window. 

4. Right‐click on ShipConstructor License Server and choose Restart. 

List Available Licenses 
To list available licenses 

1. Choose Start > All Programs > ShipConstructor2006 > Utilities > License Monitor to open the License 
Monitor. 

2. Set Server to the IP address or computer name of the license server to connect to and set the Port to the 
port number. 

Note: The default port number is 3960. See also Change the License Service Port (page 24). 

3. Click Connect. 

The License Manager displays a hierarchy of license information for the selected license server. 
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The first level of the hierarchy lists the ShipConstructor modules. 

The second level of the hierarchy lists the information about licenses for the module. 

Available – The number of available licenses for the module. 

Total – The total number of licenses for the module on the server. It Adds all the licenses from all the 
locks. 

Version – The newest ShipConstructor version that the license will support. 

Max Level – The maximum level of the total licenses that the server can license. If one lock has a Level 5 
Structure license and another lock has Level 7 Structure license then Max Level will show Level 7. 

The third level of the hierarchy lists licenses that have been checked out by a users. 

 

The domain account and the computer name are shown so you can easily notify that person to release their 
checked out license. 

Project Settings & Libraries 
There are certain settings that ShipConstructor uses throughout a project. Before you begin work on a 
project, you must set these project settings. You can also import project settings from another project or from 
an XML file that you have exported from another project. 

Each project also contains various libraries defining the stocks, materials, and so on that you can use in the 
project. Before you begin work on a project, you must set up these project libraries. 

• See the Structure manual for details on setting up general libraries and structure libraries. 

• See the Pipe manual for details on setting up pipe libraries. 

• See the Equipment and Penetrations manual for details on setting up equipment libraries and penetration 
standards. 

• See the HVAC manual for details on setting up HVAC libraries. 

You can also import project libraries from another project or from an XML file that you have exported from 
another project. 
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Set Project Settings 
To set project settings 

1. Choose ShipConstructor > Manager to open Manager. 

2. Choose General > Project Settings to open the Project Settings window. 

3. Set the options (see Project Settings in the Structure manual for details). 

4. Click OK to close the Project Settings window. 

Import Project Settings 
To import project settings 

1. Choose ShipConstructor > Manager to open Manager. 

2. Choose General > Project Settings to open the Project Settings window. 

3. Click Import to open a File Browser. 

4. Select a project file (*.PRO) or XML file (*.XML). 

5. Click Open. 

Export Project Settings 
To export project settings 

1. Choose ShipConstructor > Manager to open Manager. 

2. Choose General > Project Settings to open the Project Settings window. 

3. Click Export XML to open a File Browser. 

4. Enter a name for the XML file. 

5. Click Save. 

Import Project Libraries 
To import project libraries 

1. Choose ShipConstructor > Manager to open Manager. 

2. Choose an option from File > Import Stocks to open a File Browser. 

3. Select a project file (*.PRO) or XML file (*.XML). 

4. Click Open. 

Export Project Libraries 
To export project libraries 

1. Choose ShipConstructor > Manager to open Manager. 
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2. Choose an option from File > Export Stocks to open a File Browser. 

3. Enter a name for the XML file. 

4. Click Save. 

Appendix: Menus, Tools & Commands 

ShipConstructor Menu 
See the Structure manual for details on other ShipConstructor menu items. 

ShipConstructor > Project > New Project 

Menu............... ShipConstructor > Project > New Project 
Toolbar............ None 
Navigator ........ None 
Command....... SCNEWPROJECT 
Permissions.... Admin User 
Procedure....... Create a Project (page 3)  

Creates a new project. 

ShipConstructor > Project > Copy Project 

Menu............... ShipConstructor > Project > Copy Project 
Toolbar............ None 
Navigator ........ None 
Command....... SCCOPYPROJECT 
Permissions.... Admin User 
Procedure....... Copy a Project (page 4)  

Copies a project (including all of its stocks and drawings). 

Copy Project Window 

 

Project File 
The project file you want to copy. 
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Project Name 
The name you want to save the copied ShipConstructor project as. 

Folder 
The location you want to save the copied ShipConstructor project to. 

Username 
A username with administrative privileges. 

Password 
Your Admin password. 

Administrator 
Administrator is a stand‐alone utility that lets you set up and manage projects. 

 

Project Name 
The name of each project. 

Version 
The version number of the project database. See Update a Project Database Version (page 12) for details. 

Size (MB) 
The size of the project database (in megabytes). 

Project GUID 
The project’s ID number. Each project has a unique Project GUID. 

Next Scheduled Backup 
The date and time of the next scheduled backup. See Set Up Scheduled (Automatic) Project Backups (page 9) 
for details. 

Note: This feature is not available on SQL Express servers. 

Server Menu 

Server > Connect 

Menu............... Server > Connect 
Toolbar............ None 
Procedure....... Connect Administrator to a Server (page 2)  

Opens the Select Database Server window, letting you select the server for the projects you want to 
administer. 

Server > Disconnect 

Menu............... Server > Disconnect 
Toolbar............ None 
Procedure....... Disconnect Administrator from the Current Server (page 2)  

Closes the connection between Administrator and the current server. 
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Server > Refresh Project List 

Menu............... Server > Refresh Project List 

Toolbar............  
Procedure....... Refresh the Project List in Administrator  (page 2) 

Refreshes the list of projects in Administrator. 

Project Menu 

Project > Copy 

Menu............... Project > Copy 

Toolbar............  
Right-click....... Copy 
Procedure....... Copy a Project (page 4)  

Creates a new project that is an exact copy of the selected project but with a unique Project GUID. 

Project > Delete 

Menu............... Project > Delete 

Toolbar............  
Right-click....... Delete 
Procedure....... Delete a Project (page 8)  

Deletes the selected project. 

Project > Backup 

Menu............... Project > Backup 

Toolbar............  
Right-click....... Backup 
Procedure....... Manually Back Up a Project (page 9)  

Creates a backup of the selected project. 

Project > Restore 

Menu............... Project > Restore 

Toolbar............  
Right-click....... Restore 
Procedure....... Restore a Project Backup (page 11)  

Restores a backed up project. 

Project > Update 

Menu............... Project > Update 

Toolbar............  
Right-click....... Update 
Procedure....... Update a Project Database Version (page 12)  

Updates the database version of the selected project. 
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Project > Compact 

Menu............... Project > Compact 

Toolbar............  
Right-click....... Compact 
Procedure....... Compact a Project (page 11)  

Compacts the selected project. 

Project > Show Connected Processes 

Menu............... Project > Show Connected Processes 
Toolbar............ None 
Right-click....... Show Connected Processes 
Procedure....... Monitor Project Activity (page 8)  

Displays active user connections to the project database. 

Project > Schedule Backup 

Menu............... Project > Schedule Backup 

Toolbar............  
Right-click....... Schedule Backup 
Procedure....... Set Up Scheduled (Automatic) Project Backups (page 9)  

Lets you set up a scheduled (automatic) backup of the selected project. 

Project > Execute SQL 

Menu............... Project > Execute SQL 

Toolbar............  
Right-click....... Execute SQL 

Lets you execute an SQL script file against the selected project. 

Tools Menu 

Tools > Manage Users 

Menu............... Tools > Manage Users 

Toolbar............  
Right-click....... Manage Users 
Procedure....... User Accounts (page 19)  

Opens the Manage Users window, letting you create and edit user accounts. 

ShipConstructor Users 
Lists all ShipConstructor user accounts and which projects each user account has access to. DB Admin 
indicates user accounts with system administrator privileges. 

Change Password 
Lets you change the password for the selected user account. 

New User 
Creates a new user account. 
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Copy User 
Creates a new user account that has access to the same projects as the selected user account. 

Delete User 
Deletes the selected user account. 

Tools > Change ShipConstructor User Password 

Menu............... Tools > Change ShipConstructor User Password 
Toolbar............ None 
Procedure....... Change the System Password (page 20)  

Lets you change the system password (the password of the ShipConstructor user account). 

Tools > Re-attach Database 

Menu............... Tools > Re-attach Database 
Toolbar............ None 
Procedure....... Re-attach a Project Database to Its Server (page 12)  

Lets you re‐attach a detached project to its server. 

About Menu 

About > About Administrator 
Displays the Administrator version number. 

Right-click Menu 

Manage Users 
See Tools > Manage Users (page 31). 

Copy 
See Project > Copy (page 30). 

Delete 
See Project > Delete (page 30). 

Backup 
See Project > Backup (page 30). 

Restore 
See Project > Restore (page 30). 

Update 
See Project > Update (page 30). 

Compact 
See Project > Compact (page 31). 

Show Connected Processes 
See Project > Show Connected Processes (page 31). 

Schedule Backup 
See Project > Schedule Backup (page 31). 
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Toolbar 
 Manage Logins – See Tools > Manage Users (page 31)  

 Refresh Project List – See Server > Refresh Project List (page 30) 

 Copy Database – See Project > Copy (page 30)  

 Delete Database – See Project > Delete (page 30)  

 Backup Database – See Project > Backup (page 30)  

 Restore Database From Backup – See Project > Restore (page 30)  

 Update Database – See Project > Update (page 30)  

 Compact Database – See Project > Compact (page 31)  

 Schedule Database Backups – See Project > Schedule Backup (page 31)  

 Execute SQL – See Project > Execute SQL (page 31) 

 

Manager 
Manager is a utility that lets you set up project settings, project libraries, and user permissions. 

File > Import Stocks 

Menu............... File > Import Stocks 
Toolbar............ None 
Permissions.... The ability to edit the type of stock being imported 
Procedure....... Import Project Libraries (page 27)  

Lets you import Manager settings from another project or from an XML file that was exported from another 
project either for All Modules or for an individual menu in Manager (General, Structure, Pipe, HVAC, or 
Equipment). 

File > Export Stocks 

Menu............... File > Export Stocks 
Toolbar............ None 
Permissions.... None 
Procedure....... Export Project Libraries (page 27)  

Exports Manager settings to an XML file either for All Modules or for an individual menu in Manager 
(General, Structure, Pipe, HVAC, and Equipment). 

File > Exit 
Closes Manager. 
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General > Project Settings 

Menu............... General > Project Settings 

Toolbar............  
Navigator ........ Settings (with the project selected) 
Permissions.... None 
Procedure....... Set Project Settings (page 27)  

Opens the Project Settings window, letting you set various project‐wide settings. 

Reports 
See the Structure manual for details. 

General 
See the Structure manual for details. 

Structure 
See the Structure manual for details. 

Common Parts Catalog 
See the Structure manual for details. 

Pipe 
See the Pipe manual for details. 

HVAC 
See the HVAC manual for details. 

Hull 
See the Hull manual for details. 

General > User Permissions 

Menu............... General > User Permissions 

Toolbar............  
Navigator ........ User Permissions (with the project selected) 
Permissions.... Manager > User Permissions 
Procedure....... User Permissions  (page 21) 

Opens the User Permissions window, letting you set up user permissions and permission groups. 

Users 
Lists all users for the current project. Select a user to display their user permissions under User Overrides. 

Permission Groups 
Lists all permission groups for the current project. Check a check box to include the selected user in the 
permission group. 

Edit 
Opens the Edit Permission Group window for the selected permission group, letting you set the permissions 
for the group. 

New 
Creates a new permission group. 

Del 
Deletes the selected permission group. 
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Import 
Lets you import permission groups from another project or from an XML file that was exported from 
another project. 

Export XML 
Exports permission groups to an XML file. 

User Overrides 
Displays and lets you edit the permissions for the selected user. 

General > Materials 
Opens the Materials window, letting you create and edit materials. See Materials in the Structure manual for 
details. 

General > Manufacturers 
Opens the Manufacturers window, letting you create and edit manufacturers. See Manufacturers in the 
Structure manual for details. 

General > Finishes 
Opens the Finishes window, letting you create and edit finishes. See Finishes in the Structure manual for 
details. 

General > Insulations 
Opens the Insulation window, letting you create and edit insulation. See Insulation in the HVAC manual for 
details. 

General > Text Styles 
Opens the Text Styles window, letting you create and edit text styles. See Text Styles in the Structure manual 
for details. 

General > Accessory Packages 
Opens the Accessory Packages window, letting you create and edit accessory packages. See Accessory 
Packages in the Pipe manual for details. 

General > Naming Conventions 
Opens the Naming Conventions window, letting you create and edit naming conventions. See Naming 
Conventions in the Structure manual for details. 

General > Production Output > Label Styles 
Opens the Label Styles window, letting you create and edit label styles. See Label Styles in the Structure 
manual for details. 

General > Production Output > Dimension Styles 
Opens the Dimension Styles window, letting you create and edit dimension styles. See Dimension Styles in 
the Structure manual for details. 
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General > Production Output > Bill of Materials 
Opens the Bill of Materials window, letting you edit BOM definitions for the various disciplines. See Bill of 
Materials in the Structure manual for details. 

General > Production Output > Predefined Assembly Format 
Opens the Predefined Assembly Format window, letting you edit settings related to assemblies. See 
Predefined Assembly Format in the Structure manual for details. 

General > CPC Associated Projects 
Opens the CPC Projects window, letting you associate the project with other Common Parts Catalog (CPC) 
projects so whenever you import a stock from the CPC database, ShipConstructor automatically searches 
associated projects for additional stock information. See Common Parts Catalog (CPC) in the Structure manual 
for details. 

Structure > Stock Catalog 
Opens the Structural Stock Editor window, letting you create and edit structural stocks. See Stocks in the 
Structure manual for details. 

Structure > Piecemark Styles 
Opens the Piecemark Styles window, letting you create and edit piecemark styles. See Piecemark Styles in the 
Structure manual for details. 

Structure > User-Defined Attributes 
Opens the User-Defined Attributes window, letting you create and edit user‐defined attributes for structural 
parts and stocks. See User‐Defined Attributes in the Structure manual for details. 

Structure > Plates > Orientation Icon 
Opens the Orientation Icon window, letting you create and edit orientation icons. See Orientation Icon in the 
Structure manual for details. 

Structure > Plates > Markline Styles 
Opens the Markline Styles window, letting you create and edit markline styles. See Markline Styles in the 
Structure manual for details. 

Structure > Plates > Flange Catalog 
Opens the Flange Library window, letting you create and edit plate flanges. See Flanges in the Structure 
manual for details. 

Structure > Plates > Corner Treatments 
Opens the Corner Treatments window, letting you create and edit corner treatments. See Corner Treatments in 
the Structure manual for details. 

Structure > Plates > Green Standards 
Opens the Green Standards window, letting you create and edit green standards. See Green Standards in the 
Structure manual for details. 
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Structure > Plates > Bevel Standards 
Opens the Bevel Standards window, letting you create and edit bevel standards. See Bevel Standards in the 
Structure manual for details. 

Structure > Plates > NC Machines 
Opens the NC Machines window, letting you create and edit NC machines. See NC Machines in the Structure 
manual for details. 

Structure > Extrusions > Endcut Catalog 
Opens the Endcut Definitions window, letting you create and edit profile stock endcuts. See Endcuts in the 
Structure manual for details. 

Structure > Extrusions > Green Standards 
Opens the Green Standards window, letting you create and edit green standards. See Green Standards in the 
Structure manual for details. 

Structure > Standard Parts 
Opens the Standard Parts window, letting you create and edit standard (structural) parts. See Standard Parts 
in the Structure manual for details. 

Piping > Stock Catalog 
Opens the Pipe Stock Catalog, letting you create and edit pipe library items. See the Pipe manual for details. 

Piping > Pipe Benders 
Opens the Pipe Bending Machines window, letting you create and edit pipe bending machines. See Pipe 
Bending Machines in the Pipe manual for details. 

Piping > User-Defined Attributes 
Opens the User-Defined Attributes window, letting you create and edit user‐defined attributes for pipe parts 
and stocks. See User‐Defined Attributes in the Structure manual for details. 

HVAC > Stock Catalog 
Opens the HVAC Catalog Stock Editor, letting you create and edit end treatments, HVAC stocks, catalogs, 
specs, and connections. See the HVAC manual for details. 

HVAC > Sheet Stocks 
Opens the Sheet Stocks window, letting you create and edit sheet stocks. See Sheet Stocks in the HVAC 
manual for details. 

HVAC > User-Defined Attributes 
Opens the User-Defined Attributes window, letting you create and edit user‐defined attributes for HVAC 
parts and stocks. See User‐Defined Attributes in the Structure manual for details. 

Equipment > Equipment Library Editor 
Opens the Equipment Library Editor, letting you create and edit equipment items. See the Equipment and 
Penetrations manual for details. 
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Penetrations > Standards 
Opens the Penetration Standard Editor, letting you create and edit penetration standards. See the Equipment 
and Penetrations manual for details. 

Database Utilities > Raw Data 

Menu............... Database Utilities > Raw Data 
Toolbar............ None 
Permissions.... Manager > Edit Raw Data 
Procedure....... Edit Project Database Raw Data (page 12)  

Opens the Database Raw Data window, letting you display and edit the raw data contained in the project 
database. 

Window > 
Lets you switch between open windows in Manager. 

Note: If no windows are open, the Window menu is empty. 

License Monitor 
The License Monitor is a utility that lets you list license information and release licenses that are checked‐out. 
See Licenses (page 24). 

 

Server 
Enter the IP address or computer name of the license server you want to monitor. 

Port 
Enter the port number of the license server you want to manage. 

Connect 
Connects the License Monitor to the license server specified by IP or \\domain\computer and Port. It changes 
to Refresh after the Monitor is connected. 

Refresh 
Refreshes the information in the License Monitor by re‐connecting with the license server. You will need to 
refresh the information if the lock configuration on the server is changed or users have checked out licenses. 
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Locks Attached to Server 
Lists all the ShipConstructor locks attached to the computer and when they will expire. 

Licenses Tree 
Lists license information for the selected license server. See List Available Licenses (page 25). 
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